The billing view in the console does not show bills

Resolved
Partial outage
Started about 2 months ago Lasted about 6 hours

Affected

Console
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Update

    This affects all tenants which have an invoice created at August 2023 or earlier.

  • Identified
    Identified

    We are continuing to work on a fix for this incident.

    Users will see "Unexpected error occurred"